Report Cams Down and Forum Errors

Report cams up/down or if you need technical assistance.
amyklai
Topic Assistant
Posts: 6698
Joined: Feb 22, 2018

Re: Report Cams Down and Forum Errors

Post by amyklai » Mon Jan 06, 2020 6:18 pm

6.17p Any update on the white Rock Cam fix? thank you

User avatar
JudyB
Admin
Posts: 7972
Joined: Dec 09, 2017
Location: Midcoast Maine

Re: Report Cams Down and Forum Errors

Post by JudyB » Tue Jan 07, 2020 7:19 am

amyklai wrote:
Mon Jan 06, 2020 6:18 pm
6.17p Any update on the white Rock Cam fix? thank you
Thanks for the reminder, Amy - I just sent an email to Ken, and will post when I get an update.

User avatar
JudyB
Admin
Posts: 7972
Joined: Dec 09, 2017
Location: Midcoast Maine

Re: Report Cams Down and Forum Errors

Post by JudyB » Tue Jan 07, 2020 12:16 pm

White Rock cams are streaming - thanks, Ken!

amyklai
Topic Assistant
Posts: 6698
Joined: Feb 22, 2018

Re: Report Cams Down and Forum Errors

Post by amyklai » Tue Jan 07, 2020 2:24 pm

JudyB wrote:
Tue Jan 07, 2020 12:16 pm
White Rock cams are streaming - thanks, Ken!
Thank you !

User avatar
Sandy_W
Topic Assistant
Posts: 32478
Joined: Feb 22, 2018
Location: Arkansas

Re: Report Cams Down and Forum Errors

Post by Sandy_W » Sat Jan 11, 2020 7:14 am

7:15 pm reporting the Delta 2 embedded cams are offline. I checked earlier...maybe four hours ago and they were offline then as well.
“Eagles: When they walk, they stumble. They are not what one would call graceful. They were not designed to walk. They fly. And when they fly, oh, how they fly, so free, so graceful. They see from the sky what we never see.” – Unknown

User avatar
JudyB
Admin
Posts: 7972
Joined: Dec 09, 2017
Location: Midcoast Maine

Re: Report Cams Down and Forum Errors

Post by JudyB » Sat Jan 11, 2020 8:20 am

Sandy_W wrote:
Sat Jan 11, 2020 7:14 am
7:15 pm reporting the Delta 2 embedded cams are offline. I checked earlier...maybe four hours ago and they were offline then as well.
Thanks, Sandy -

It looks as if they are back online now - perhaps Ken did a morning check of the cams and rebooted them. Just looked back, and dvr only goes back 47 minutes, so I'm guessing someone did a reboot then. :thumlft:

User avatar
IrishEyes
Forum Assistant
Posts: 69474
Joined: Feb 09, 2018
Location: Nova Scotia, Canada

Re: Report Cams Down and Forum Errors

Post by IrishEyes » Mon Jan 13, 2020 6:37 am

MONDAY , JANUARY 13 , 2020

Good Morning Judy

6:32a Nest Time

The Embedded and Direct Access Zoomer cams are all down .. the last live stream was 12 hours .. it was very windy on H Mills ..


Heather Posted the Power Outages Map on the H Mills nest thread
viewtopic.php?p=272621#p272621

Thank You
Bev
Image

HELPFUL HINTS...Be Respectful !....Bev...member since 08/04/09

User avatar
JudyB
Admin
Posts: 7972
Joined: Dec 09, 2017
Location: Midcoast Maine

Re: Report Cams Down and Forum Errors

Post by JudyB » Mon Jan 13, 2020 7:41 am

Thanks for posting here, Bev! Looking at the outage maps Heather posted, it does look like the power is out there.

User avatar
IrishEyes
Forum Assistant
Posts: 69474
Joined: Feb 09, 2018
Location: Nova Scotia, Canada

Re: Report Cams Down and Forum Errors

Post by IrishEyes » Tue Jan 14, 2020 6:29 am

TUESDAY, JANUARY 14, 202O

Good Morning Judy !

Re the H Mills Cams

Heather reported S Cam is live since 8:17pm last night ..

N Cam is down

Re this morning

5:58a
N Cam is down and S Cam it struggling to cut in


North Zoomer Cam is still down .... I can't connect to it '

South Zoomer Cam is streaming ..no picture . the IR is not working

Maybe a reboot of the S Cam will help.

Thank You

Bev
Image

HELPFUL HINTS...Be Respectful !....Bev...member since 08/04/09

User avatar
JudyB
Admin
Posts: 7972
Joined: Dec 09, 2017
Location: Midcoast Maine

Re: Report Cams Down and Forum Errors

Post by JudyB » Tue Jan 14, 2020 7:23 am

IrishEyes wrote:
Tue Jan 14, 2020 6:29 am
TUESDAY, JANUARY 14, 202O

Good Morning Judy !

Re the H Mills Cams

Heather reported S Cam is live since 8:17pm last night ..

N Cam is down

Re this morning

5:58a
N Cam is down and S Cam it struggling to cut in


North Zoomer Cam is still down .... I can't connect to it '

South Zoomer Cam is streaming ..no picture . the IR is not working

Maybe a reboot of the S Cam will help.

Thank You

Bev
I'm rebooting South. Heading out for an appointment soon - will be able to check my phone in a couple of hours, though I won't be able to do anything with the cams until mid-afternoon cam time. I also can not connect with North.

I wonder if the IR is on the North cam?

User avatar
IrishEyes
Forum Assistant
Posts: 69474
Joined: Feb 09, 2018
Location: Nova Scotia, Canada

Re: Report Cams Down and Forum Errors

Post by IrishEyes » Tue Jan 14, 2020 7:31 am

JudyB wrote:
Tue Jan 14, 2020 7:23 am
IrishEyes wrote:
Tue Jan 14, 2020 6:29 am
TUESDAY, JANUARY 14, 202O

Good Morning Judy !

Re the H Mills Cams

Heather reported S Cam is live since 8:17pm last night ..

N Cam is down

Re this morning

5:58a
N Cam is down and S Cam it struggling to cut in


North Zoomer Cam is still down .... I can't connect to it '

South Zoomer Cam is streaming ..no picture . the IR is not working

Maybe a reboot of the S Cam will help.

Thank You

Bev
I'm rebooting South. Heading out for an appointment soon - will be able to check my phone in a couple of hours, though I won't be able to do anything with the cams until mid-afternoon cam time. I also can not connect with North.

I wonder if the IR is on the North cam?

Thanks Judy and take care :huggie:
Image

HELPFUL HINTS...Be Respectful !....Bev...member since 08/04/09

amyklai
Topic Assistant
Posts: 6698
Joined: Feb 22, 2018

Re: Report Cams Down and Forum Errors

Post by amyklai » Tue Jan 14, 2020 8:42 am

8.42a Can thee WR cameras be rebooted ? i did the North one , but still sticking

User avatar
JudyB
Admin
Posts: 7972
Joined: Dec 09, 2017
Location: Midcoast Maine

Re: Report Cams Down and Forum Errors

Post by JudyB » Tue Jan 14, 2020 10:01 am

amyklai wrote:
Tue Jan 14, 2020 8:42 am
8.42a Can thee WR cameras be rebooted ? i did the North one , but still sticking
I’ll send a message to Ken, but if your reboot didn’t help, it may be the cold temperatures affecting the ability of the cam to move.

amyklai
Topic Assistant
Posts: 6698
Joined: Feb 22, 2018

Re: Report Cams Down and Forum Errors

Post by amyklai » Wed Jan 15, 2020 4:13 am

JudyB wrote:
Tue Jan 14, 2020 10:01 am
amyklai wrote:
Tue Jan 14, 2020 8:42 am
8.42a Can thee WR cameras be rebooted ? i did the North one , but still sticking
I’ll send a message to Ken, but if your reboot didn’t help, it may be the cold temperatures affecting the ability of the cam to move.
thank you judy , i am having skin cell carcinoma taken care of today , so ill be gone for most of the day

User avatar
IrishEyes
Forum Assistant
Posts: 69474
Joined: Feb 09, 2018
Location: Nova Scotia, Canada

Re: Report Cams Down and Forum Errors

Post by IrishEyes » Wed Jan 15, 2020 4:37 am

Good Morning Judy ..

Re H Mills South Cam
4:22am
Very windy and IR is not working on the S Cam .. I think the controls need to be adjusted.
Screen Shot 2020-01-15 at 8.22.48 AM.png
Thank You
Bev

PS I also find the forum slow and slow to load scaps !
Image

HELPFUL HINTS...Be Respectful !....Bev...member since 08/04/09

User avatar
JudyB
Admin
Posts: 7972
Joined: Dec 09, 2017
Location: Midcoast Maine

Re: Report Cams Down and Forum Errors

Post by JudyB » Wed Jan 15, 2020 8:29 am

IrishEyes wrote:
Wed Jan 15, 2020 4:37 am
Good Morning Judy ..

Re H Mills South Cam
4:22am
Very windy and IR is not working on the S Cam .. I think the controls need to be adjusted.

Thank You
Bev

PS I also find the forum slow and slow to load scaps !
Good morning, Bev -

I've taken a look at the controls and don't see anything that I dare change now while the cam is working. I'll try to take a look later this evening or tomorrow morning while it's dark in BC.

I did mention the issue to Ken, and he may take a look later. I will mention that he's snowed in at present, so not able to do a site visit on any of the cams for at least a couple of days.

User avatar
IrishEyes
Forum Assistant
Posts: 69474
Joined: Feb 09, 2018
Location: Nova Scotia, Canada

Re: Report Cams Down and Forum Errors

Post by IrishEyes » Wed Jan 15, 2020 8:45 am

JudyB wrote:
Wed Jan 15, 2020 8:29 am
IrishEyes wrote:
Wed Jan 15, 2020 4:37 am
Good Morning Judy ..

Re H Mills South Cam
4:22am
Very windy and IR is not working on the S Cam .. I think the controls need to be adjusted.

Thank You
Bev

PS I also find the forum slow and slow to load scaps !
Good morning, Bev -

I've taken a look at the controls and don't see anything that I dare change now while the cam is working. I'll try to take a look later this evening or tomorrow morning while it's dark in BC.

I did mention the issue to Ken, and he may take a look later. I will mention that he's snowed in at present, so not able to do a site visit on any of the cams for at least a couple of days.
Thank You Judy, I understand .. I think all of us at H Mills are happy we have one cam streaming on H Mills and re Ken.. we don't expect Ken to make a site visit until it is safe to do so ..
Image

HELPFUL HINTS...Be Respectful !....Bev...member since 08/04/09

User avatar
Sandy_W
Topic Assistant
Posts: 32478
Joined: Feb 22, 2018
Location: Arkansas

Re: Report Cams Down and Forum Errors

Post by Sandy_W » Thu Jan 16, 2020 3:28 pm

3:22 pm from Delta 2, I have been having issues trying to use the DVR rollback and the cam will freeze with the spinning circles. Try to refreshed numerous times attempting to get s'caps, as I am doing now on the east cam. Finally went to the west DVR to get s'caps. Sometimes I just give up in trying to use the rollback DVR feature and try to describe what I saw while zooming or watching. Any suggestions would be helpful. Thanks.
2020-01-16_17-24-37.jpg
“Eagles: When they walk, they stumble. They are not what one would call graceful. They were not designed to walk. They fly. And when they fly, oh, how they fly, so free, so graceful. They see from the sky what we never see.” – Unknown

User avatar
IrishEyes
Forum Assistant
Posts: 69474
Joined: Feb 09, 2018
Location: Nova Scotia, Canada

Re: Report Cams Down and Forum Errors

Post by IrishEyes » Thu Jan 16, 2020 4:59 pm

Hi Judy ~

4:44pm
Re H Mills


Very windy with heavy snow at H Mills

Both Embedded cams are down

4:48pm
N Cam is back

S Cam still down and I can't connect to the SPTZ Direct Access Zoomer Cam

Thank You

Bev

PS .. I think this is a wait and see situation. JMO
Image

HELPFUL HINTS...Be Respectful !....Bev...member since 08/04/09

User avatar
IrishEyes
Forum Assistant
Posts: 69474
Joined: Feb 09, 2018
Location: Nova Scotia, Canada

Re: Report Cams Down and Forum Errors

Post by IrishEyes » Mon Jan 20, 2020 12:47 pm

MONDAY, JANUARY 20, 2020

GoodAfternoon Judy

Re HMills

12:44pm.Nest Time

The N Cam is sputtering ... maybe a reboot will help when you have time .

Thank You
Bev

PS For the record.. The S Cam is still down... we are waiting to see if it comes .
Image

HELPFUL HINTS...Be Respectful !....Bev...member since 08/04/09

User avatar
JudyB
Admin
Posts: 7972
Joined: Dec 09, 2017
Location: Midcoast Maine

Re: Report Cams Down and Forum Errors

Post by JudyB » Tue Jan 21, 2020 8:00 am

IrishEyes wrote:
Mon Jan 20, 2020 12:47 pm
MONDAY, JANUARY 20, 2020

GoodAfternoon Judy

Re HMills

12:44pm.Nest Time

The N Cam is sputtering ... maybe a reboot will help when you have time .

Thank You
Bev

PS For the record.. The S Cam is still down... we are waiting to see if it comes .
Thanks, Bev - I'm afraid I was a bit under the weather yesterday so didn't get here to check for messages - does North still need a reboot?

User avatar
IrishEyes
Forum Assistant
Posts: 69474
Joined: Feb 09, 2018
Location: Nova Scotia, Canada

Re: Report Cams Down and Forum Errors

Post by IrishEyes » Tue Jan 21, 2020 8:08 am

JudyB wrote:
Tue Jan 21, 2020 8:00 am
IrishEyes wrote:
Mon Jan 20, 2020 12:47 pm
MONDAY, JANUARY 20, 2020

GoodAfternoon Judy

Re HMills

12:44pm.Nest Time

The N Cam is sputtering ... maybe a reboot will help when you have time .

Thank You
Bev

PS For the record.. The S Cam is still down... we are waiting to see if it comes .
Thanks, Bev - I'm afraid I was a bit under the weather yesterday so didn't get here to check for messages - does North still need a reboot?

Sorry your weren't feeling well Judy :huggie: the cam just went down and came back again... did you reboot it ??

PS.. It had spinning circle before that and I refreshed and it came back.

It seems OK now.
Image

HELPFUL HINTS...Be Respectful !....Bev...member since 08/04/09

User avatar
JudyB
Admin
Posts: 7972
Joined: Dec 09, 2017
Location: Midcoast Maine

Re: Report Cams Down and Forum Errors

Post by JudyB » Tue Jan 21, 2020 8:14 am

IrishEyes wrote:
Tue Jan 21, 2020 8:08 am
JudyB wrote:
Tue Jan 21, 2020 8:00 am

Thanks, Bev - I'm afraid I was a bit under the weather yesterday so didn't get here to check for messages - does North still need a reboot?

Sorry your weren't feeling well Judy :huggie: the cam just went down and came back again... did you reboot it ??
No. Ken may be rebooting them (or the Wowza server) from time to time - I've seen the Surrey cams go briefly black one after the other.


I also cannot log into Harrison South. I'll send a message to Ken - sometimes he can do things remotely with his connection to the computer out there, but it may eventually require a site visit.

User avatar
IrishEyes
Forum Assistant
Posts: 69474
Joined: Feb 09, 2018
Location: Nova Scotia, Canada

Re: Report Cams Down and Forum Errors

Post by IrishEyes » Tue Jan 21, 2020 8:21 am

JudyB wrote:
Tue Jan 21, 2020 8:14 am
IrishEyes wrote:
Tue Jan 21, 2020 8:08 am
JudyB wrote:
Tue Jan 21, 2020 8:00 am

Thanks, Bev - I'm afraid I was a bit under the weather yesterday so didn't get here to check for messages - does North still need a reboot?

Sorry your weren't feeling well Judy :huggie: the cam just went down and came back again... did you reboot it ??
No. Ken may be rebooting them (or the Wowza server) from time to time - I've seen the Surrey cams go briefly black one after the other.


I also cannot log into Harrison South. I'll send a message to Ken - sometimes he can do things remotely with his connection to the computer out there, but it may eventually require a site visit.
Thank you Judy and please get some rest today :huggie: There is a nasty bug on the go here .. Agnes and Kyle both have a nasty cold.. :(
Image

HELPFUL HINTS...Be Respectful !....Bev...member since 08/04/09

User avatar
Jean
Topic Assistant
Posts: 25055
Joined: Feb 19, 2018
Location: Langley, BC

Re: Report Cams Down and Forum Errors

Post by Jean » Tue Jan 21, 2020 2:44 pm

2:30pm.............Hi Judy and all........sorry to hear you haven't been well either. Not a good time of the year I think. Spring can't come soon enough for me. I've had both vertigo and gout to contend with since early December. Finally almost back to my old self.

General questions.......nothing urgent.........

At Delta2 we are having an issue with the embedded cams. This seems to have started a couple of months ago maybe. The embedded cams are getting spinning circles frequently. The cams do usually come back on their own but we find we often have to refresh our screens to make them appear current again while we are zooming. And then they will spin again a few minutes later. When they do spin this shows up on the rollback as a blip, in other words we have lost a moment or two of the actual footage. When zoomers are looking to find a particular thing we often spend a long time trying to get this moment before we realize that it just isn't there to find. And zoomers need these embedded cams to work properly while they are zooming the cams as that is where we grab our s'caps from. So that is wasted time when we don't have a lot of time to be on the cams. Yesterday it was like that with me and I finally gave up in frustration. What makes it worse is that with a very long rollback time now it is a real challenge to locate a particular moment so we can get a s'cap from it. Zoomers are mostly looking for things within a shorter time frame and this long rollback makes it an onerous task. When we had a shorter rollback maybe 4 hours or so.........it seemed to be better. The end result is that using the rollback is not an efficient, useful tool anymore.........and I think we are all wanting to leave it alone now unless something urgent happens. At first I thought our cold, windy weather was to blame for the spinning circles, but it has gone on for so long now I wonder if there is some other reason.
"Volunteers do not necessarily have the time..............they have the heart"..........Elizabeth Andrew

(Member since 9/10/11)

User avatar
JudyB
Admin
Posts: 7972
Joined: Dec 09, 2017
Location: Midcoast Maine

Re: Report Cams Down and Forum Errors

Post by JudyB » Wed Jan 22, 2020 3:30 pm

Jean wrote:
Tue Jan 21, 2020 2:44 pm
2:30pm.............Hi Judy and all........sorry to hear you haven't been well either. Not a good time of the year I think. Spring can't come soon enough for me. I've had both vertigo and gout to contend with since early December. Finally almost back to my old self.

General questions.......nothing urgent.........

At Delta2 we are having an issue with the embedded cams. This seems to have started a couple of months ago maybe. The embedded cams are getting spinning circles frequently. The cams do usually come back on their own but we find we often have to refresh our screens to make them appear current again while we are zooming. And then they will spin again a few minutes later. When they do spin this shows up on the rollback as a blip, in other words we have lost a moment or two of the actual footage. When zoomers are looking to find a particular thing we often spend a long time trying to get this moment before we realize that it just isn't there to find. And zoomers need these embedded cams to work properly while they are zooming the cams as that is where we grab our s'caps from. So that is wasted time when we don't have a lot of time to be on the cams. Yesterday it was like that with me and I finally gave up in frustration. What makes it worse is that with a very long rollback time now it is a real challenge to locate a particular moment so we can get a s'cap from it. Zoomers are mostly looking for things within a shorter time frame and this long rollback makes it an onerous task. When we had a shorter rollback maybe 4 hours or so.........it seemed to be better. The end result is that using the rollback is not an efficient, useful tool anymore.........and I think we are all wanting to leave it alone now unless something urgent happens. At first I thought our cold, windy weather was to blame for the spinning circles, but it has gone on for so long now I wonder if there is some other reason.
Glad to hear that you're feeling better, Jean - that's a long time to be under the weather!

Hmm :chin:

Do you know how long it's been since the cams have been rebooted? That sometimes helps with the spinning circle, and I'll be happy to reboot one or both of them - or you can. Maybe try rebooting one first, to see if it makes a difference.

I'm sort of thinking out loud here - if when the embedded cams go to a spinning circle, there's no data being recorded to the dvr (so a blip) - that suggests that the cam may be having trouble connecting to YouTube. I'm also wondering how long it's been since the Wowza server has been rebooted - which is a question for Ken, and I'll ask.

One thing I sometimes do when watching a cam where something is happening is scribble the time stamp when something interesting occurs. I tend to record visits then take my s'caps from the recording, and that helps me find the spot on the recording when I had a good look at the male's eye, for instance. And I don't zoom as much as you and your team, but when I do, it also helps me know when exactly the male landed so I can get a picture of him with the stick (or whatever).

By the way, I've been watching the Delta embedded cams while typing (it's now 3:11 pm) and someone is zooming - and so far I haven't had a spinning circle. And I know things like that never happen when someone's watching for them. But if you - or whoever is zooming - is getting a spinning circle with missing data, I'd have to rethink my theory.

As far as the rollback time - I have not been able to find a way to set that on YouTube. Usually when I reboot a cam, it resets the dvr - but that doesn't always happen, and I'm not sure why. I don't suppose there's a certain time when the eagles typically do interesting things? You could try doing a reboot in the morning once you've checked for overnight activity - that should give you a shorter rollback period for at least the first part of the daylight hours - and probably most of them during this time of short days and long nights. Or I can try doing that if I'm online in the morning, if you'd like me to do it (I'd check to see if anyone is signed in to zoom and coordinate with them if there is).

Beyond that, I don't know what to suggest. Now that we have fiber optic service at Delta, there should be plenty of bandwidth for the two-way connection to the cams that zoomers need plus the upload to Wowza to send the signal to YouTube. Weather might be a factor on those very windy days, but I wouldn't think it would be otherwise.

Let me know if there's something you want to try that you'd like my help with - and I'll ask Ken about the Wowza server. Good luck!

It's now 3:30, and I still haven't had a spinning circle.

User avatar
JudyB
Admin
Posts: 7972
Joined: Dec 09, 2017
Location: Midcoast Maine

Re: Report Cams Down and Forum Errors

Post by JudyB » Wed Jan 22, 2020 6:03 pm

Adding to my previous post....

I was away from my computer until 5:59 pm, and found a spinning arrow on the East embedded cam when I returned. I clicked "live" and it jumped to the present. I went back to the beginning of the dvr, and it was 12 hours back, suggesting nothing was deleted by the spinning circle this time.

The dvr on West also went back 12 hours.

All of which proves nothing, beyond the fact that it's really hard to debug things that happen intermittently. But we'll keep trying. :thumlft:

User avatar
IrishEyes
Forum Assistant
Posts: 69474
Joined: Feb 09, 2018
Location: Nova Scotia, Canada

Re: Report Cams Down and Forum Errors

Post by IrishEyes » Wed Jan 22, 2020 6:11 pm

JudyB wrote:
Wed Jan 22, 2020 6:03 pm

I was away from my computer until 5:59 pm, and found a spinning arrow on the East embedded cam when I returned. I clicked "live" and it jumped to the present. I went back to the beginning of the dvr, and it was 12 hours back, suggesting nothing was deleted by the spinning circle this time.

The dvr on West also went back 12 hours.

All of which proves nothing, beyond the fact that it's really hard to debug things that happen intermittently. But we'll keep trying. :thumlft:

Judy .. I do the same on H Mills !

Bev
Image

HELPFUL HINTS...Be Respectful !....Bev...member since 08/04/09

User avatar
Jean
Topic Assistant
Posts: 25055
Joined: Feb 19, 2018
Location: Langley, BC

Re: Report Cams Down and Forum Errors

Post by Jean » Wed Jan 22, 2020 10:02 pm

10:01pm..........Judy, I have rebooted both zoomer cams at Delta. Will have to wait and see if this makes any difference to getting spinning circles or not.

Also..............the blips I was talking about before are what occurs as we watch the rollback of the cams. I think maybe the recording is made, don't know but when we try to use the red line to view something and actually watch the video playback as things happen, it will sometimes skip over a moment as if it has not been recorded................but the playback will still go back 12 hours. That is not affected. This blip usually coincides with the time there was a spinning circle there.

Also.........as I look now I see that the E cam seems to be going on and off.
2.JPG
5.JPG
6.JPG


At this time they are both ON again.
"Volunteers do not necessarily have the time..............they have the heart"..........Elizabeth Andrew

(Member since 9/10/11)

User avatar
Sandy_W
Topic Assistant
Posts: 32478
Joined: Feb 22, 2018
Location: Arkansas

Re: Report Cams Down and Forum Errors

Post by Sandy_W » Thu Jan 23, 2020 2:57 am

2:55 am checking in at Delta 2 and find the east embedded cam is offline. I don't know when it happened however.
2020-01-23_4-55-31.jpg
“Eagles: When they walk, they stumble. They are not what one would call graceful. They were not designed to walk. They fly. And when they fly, oh, how they fly, so free, so graceful. They see from the sky what we never see.” – Unknown

Post Reply

Return to “Technical Help”